summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2016-09-24 19:38:49 +0100
committerAlice Ferrazzi <alicef@gentoo.org>2016-09-24 19:38:49 +0100
commitf16b73fc895e5e213c9e8b59db8268907cd0cb37 (patch)
treefb925b2216f00793b85ed37d2b44bcd14f082cf6 /dev-python/libcloud/libcloud-1.2.1.ebuild
parentdev-python/paramiko: add maintainer (diff)
downloadgentoo-f16b73fc895e5e213c9e8b59db8268907cd0cb37.tar.gz
gentoo-f16b73fc895e5e213c9e8b59db8268907cd0cb37.tar.bz2
gentoo-f16b73fc895e5e213c9e8b59db8268907cd0cb37.zip
dev-python/libcloud: version bump to 1.2.1
updated copyright Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/libcloud/libcloud-1.2.1.ebuild')
-rw-r--r--dev-python/libcloud/libcloud-1.2.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/libcloud/libcloud-1.2.1.ebuild b/dev-python/libcloud/libcloud-1.2.1.ebuild
new file mode 100644
index 000000000000..c83366bf9cb7
--- /dev/null
+++ b/dev-python/libcloud/libcloud-1.2.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# py3 dropped due to failing tests once lockfile installed
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Unified Interface to the Cloud - python support libs"
+HOMEPAGE="http://libcloud.apache.org/index.html"
+SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/lockfile[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' python{2_7,3_4} pypy)
+ )"
+
+S="${WORKDIR}/apache-${P}"
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples
+ mv example_*.py examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}