summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-11-22 11:27:36 -0500
committerMike Gilbert <floppym@gentoo.org>2017-11-22 11:28:29 -0500
commit7e1775ec67ba2e4d390c254b5d5a8074d1cacb4d (patch)
tree8be6f7a56674ba9ff422104c60e7271e9b587779 /dev-python/m2crypto/m2crypto-0.27.0.ebuild
parentdev-util/docker-ls: Version bump to 0.3.1 (diff)
downloadgentoo-7e1775ec67ba2e4d390c254b5d5a8074d1cacb4d.tar.gz
gentoo-7e1775ec67ba2e4d390c254b5d5a8074d1cacb4d.tar.bz2
gentoo-7e1775ec67ba2e4d390c254b5d5a8074d1cacb4d.zip
dev-python/m2crypto: fix build on x32
Closes: https://bugs.gentoo.org/617946 Package-Manager: Portage-2.3.15, Repoman-2.3.6_p7
Diffstat (limited to 'dev-python/m2crypto/m2crypto-0.27.0.ebuild')
-rw-r--r--dev-python/m2crypto/m2crypto-0.27.0.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/m2crypto/m2crypto-0.27.0.ebuild b/dev-python/m2crypto/m2crypto-0.27.0.ebuild
index d5e3b6201594..7c3f0565c4e4 100644
--- a/dev-python/m2crypto/m2crypto-0.27.0.ebuild
+++ b/dev-python/m2crypto/m2crypto-0.27.0.ebuild
@@ -36,6 +36,14 @@ S="${WORKDIR}/${MY_PN}-${PV}"
RESTRICT=test
python_compile() {
+ # setup.py looks at platform.machine() to determine swig options.
+ # For exotic ABIs, we need to give swig a hint.
+ # https://bugs.gentoo.org/617946
+ # TODO: Fix cross-compiles
+ local -x SWIG_FEATURES=
+ case ${ABI} in
+ x32) SWIG_FEATURES="-D__ILP32__" ;;
+ esac
distutils-r1_python_compile --openssl="${EPREFIX}"/usr
}