summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/m2crypto/m2crypto-0.27.0.ebuild')
-rw-r--r--dev-python/m2crypto/m2crypto-0.27.0.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/m2crypto/m2crypto-0.27.0.ebuild b/dev-python/m2crypto/m2crypto-0.27.0.ebuild
index d5e3b6201594..7c3f0565c4e4 100644
--- a/dev-python/m2crypto/m2crypto-0.27.0.ebuild
+++ b/dev-python/m2crypto/m2crypto-0.27.0.ebuild
@@ -36,6 +36,14 @@ S="${WORKDIR}/${MY_PN}-${PV}"
RESTRICT=test
python_compile() {
+ # setup.py looks at platform.machine() to determine swig options.
+ # For exotic ABIs, we need to give swig a hint.
+ # https://bugs.gentoo.org/617946
+ # TODO: Fix cross-compiles
+ local -x SWIG_FEATURES=
+ case ${ABI} in
+ x32) SWIG_FEATURES="-D__ILP32__" ;;
+ esac
distutils-r1_python_compile --openssl="${EPREFIX}"/usr
}