summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-22 10:42:49 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-22 10:42:49 +0300
commitee7b032d9a0e20b9d84b10fb525ea8adb9632e8c (patch)
treeb5ebbf6ac85aa37d06dceb16cec0bed5dc3996ab /dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.6.0.ebuild
parentdev-python/botocore: Stabilize 1.27.88 ALLARCHES, #877867 (diff)
downloadgentoo-ee7b032d9a0e20b9d84b10fb525ea8adb9632e8c.tar.gz
gentoo-ee7b032d9a0e20b9d84b10fb525ea8adb9632e8c.tar.bz2
gentoo-ee7b032d9a0e20b9d84b10fb525ea8adb9632e8c.zip
dev-python/mkdocs-minify-plugin: add 0.6.0, enable tests
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.6.0.ebuild')
-rw-r--r--dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.6.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.6.0.ebuild b/dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.6.0.ebuild
new file mode 100644
index 000000000000..c439b9402e5b
--- /dev/null
+++ b/dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="An MkDocs plugin to minify HTML and/or JS files prior to being written to disk"
+HOMEPAGE="
+ https://github.com/byrnereese/mkdocs-minify-plugin
+ https://pypi.org/project/mkdocs-minify-plugin/
+"
+SRC_URI="
+ https://github.com/byrnereese/mkdocs-minify-plugin/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/csscompressor-0.9.5[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.4.1[${PYTHON_USEDEP}]
+ >=app-text/htmlmin-0.1.12[${PYTHON_USEDEP}]
+ >=dev-python/jsmin-3.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ~dev-python/mkdocs-minify-plugin-${PV}[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest