summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-11 10:57:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-11 12:47:00 +0200
commit315f1b0d75754b806d434fa26dd1c6d383f21608 (patch)
tree2fb4869788c16ddce45be24973f2c109253b492e /dev-python/moto
parentdev-python/astroid: Bump to 2.5.3 (diff)
downloadgentoo-315f1b0d75754b806d434fa26dd1c6d383f21608.tar.gz
gentoo-315f1b0d75754b806d434fa26dd1c6d383f21608.tar.bz2
gentoo-315f1b0d75754b806d434fa26dd1c6d383f21608.zip
dev-python/moto: Force-disable pytest-django to fix test failures
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/moto-2.0.2.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/moto/moto-2.0.2.ebuild b/dev-python/moto/moto-2.0.2.ebuild
index 9116b3688f7f..3fd5af1d7a64 100644
--- a/dev-python/moto/moto-2.0.2.ebuild
+++ b/dev-python/moto/moto-2.0.2.ebuild
@@ -65,10 +65,7 @@ python_prepare_all() {
}
python_test() {
- local deselect=(
- # network
- tests/test_stepfunctions/test_stepfunctions.py::test_state_machine_creation_fails_with_invalid_names
- )
-
- epytest -m 'not network' ${deselect[@]/#/--deselect }
+ # pytest-django causes freezegun try to mangle stuff inside django
+ # which fails when django is not really used
+ epytest -p no:django -m 'not network'
}