summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-15 23:55:28 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-15 23:55:28 -0600
commit4f892bed74a8d0a86ea78e8cc088125d5f73cca3 (patch)
tree6647be00c44106cfc154ea7644a0d360af7ef70e /dev-python/msgpack/msgpack-0.5.1.ebuild
parentdev-python/oslo-utils: 3.35.0 bup (diff)
downloadgentoo-4f892bed74a8d0a86ea78e8cc088125d5f73cca3.tar.gz
gentoo-4f892bed74a8d0a86ea78e8cc088125d5f73cca3.tar.bz2
gentoo-4f892bed74a8d0a86ea78e8cc088125d5f73cca3.zip
dev-python/msgpack: 0.5.1 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/msgpack/msgpack-0.5.1.ebuild')
-rw-r--r--dev-python/msgpack/msgpack-0.5.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/msgpack/msgpack-0.5.1.ebuild b/dev-python/msgpack/msgpack-0.5.1.ebuild
new file mode 100644
index 000000000000..2fbeb83213b5
--- /dev/null
+++ b/dev-python/msgpack/msgpack-0.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="${PN}-python"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="MessagePack (de)serializer for Python"
+HOMEPAGE="http://msgpack.org https://github.com/msgpack/msgpack-python/ https://pypi.python.org/pypi/msgpack-python/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ py.test test || die "Tests fail with ${EPYTHON}"
+}