summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-10-21 10:47:16 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-10-21 10:55:36 -0500
commitfb353aefadde9f6ba45281f1f063548dec5ffbf5 (patch)
tree74b93d4971198b204ae84f1e3baec4d57e717bd8 /dev-python/notify2/notify2-0.3.ebuild
parentdev-db/etcd: remove old versions (diff)
downloadgentoo-fb353aefadde9f6ba45281f1f063548dec5ffbf5.tar.gz
gentoo-fb353aefadde9f6ba45281f1f063548dec5ffbf5.tar.bz2
gentoo-fb353aefadde9f6ba45281f1f063548dec5ffbf5.zip
dev-python/notify2: adding for pulseaudio-dlna
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/notify2/notify2-0.3.ebuild')
-rw-r--r--dev-python/notify2/notify2-0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/notify2/notify2-0.3.ebuild b/dev-python/notify2/notify2-0.3.ebuild
new file mode 100644
index 000000000000..cb20f99de526
--- /dev/null
+++ b/dev-python/notify2/notify2-0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to DBus notifications."
+HOMEPAGE="https://bitbucket.org/takluyver/pynotify2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+ distutils-r1_python_install_all
+}