summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2019-01-21 21:02:01 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-01-21 23:48:24 +0100
commitdf9408d0c5011680924c16e66b8473953a56462e (patch)
tree933ee6e26be68228ca3e1c54d8de738ec1d2c91c /dev-python/nuitka/nuitka-0.6.0.6.ebuild
parentdev-vcs/hub: 2.7.1 bump (diff)
downloadgentoo-df9408d0c5011680924c16e66b8473953a56462e.tar.gz
gentoo-df9408d0c5011680924c16e66b8473953a56462e.tar.bz2
gentoo-df9408d0c5011680924c16e66b8473953a56462e.zip
dev-python/nuitka: version bump to 0.6.0.6.
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Oz N Tiram <oz.tiram@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10883 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/nuitka/nuitka-0.6.0.6.ebuild')
-rw-r--r--dev-python/nuitka/nuitka-0.6.0.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/nuitka/nuitka-0.6.0.6.ebuild b/dev-python/nuitka/nuitka-0.6.0.6.ebuild
new file mode 100644
index 000000000000..0d55ac76041d
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6)
+inherit distutils-r1
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="http://www.nuitka.net"
+SRC_URI="http://nuitka.net/releases/${P^}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-util/scons[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${P^}"
+
+pkg_postinst() {
+ elog "nuitka needs app-admin/chrpath for building"
+ elog "stand-alone executables"
+}