summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-11-23 08:45:35 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-23 08:46:10 +0100
commitd27b5cd9c1c4ef67f73463206bd0e009ed5039db (patch)
tree7e64823d908d08ff330c8ffbf13cc152658e3c86 /dev-python/oct2py/oct2py-3.6.0.ebuild
parentmedia-sound/moc: version bumps to 2.5.2 and 2.6_alpha3 (diff)
downloadgentoo-d27b5cd9c1c4ef67f73463206bd0e009ed5039db.tar.gz
gentoo-d27b5cd9c1c4ef67f73463206bd0e009ed5039db.tar.bz2
gentoo-d27b5cd9c1c4ef67f73463206bd0e009ed5039db.zip
dev-python/oct2py: Version bump to 3.6.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/oct2py/oct2py-3.6.0.ebuild')
-rw-r--r--dev-python/oct2py/oct2py-3.6.0.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/oct2py/oct2py-3.6.0.ebuild b/dev-python/oct2py/oct2py-3.6.0.ebuild
new file mode 100644
index 000000000000..b8a4d0dc6a51
--- /dev/null
+++ b/dev-python/oct2py/oct2py-3.6.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python to GNU Octave bridge"
+HOMEPAGE="
+ https://pypi.python.org/pypi/oct2py
+ http://pythonhosted.org/oct2py/
+ https://github.com/blink1073/oct2py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.12[${PYTHON_USEDEP}]
+ >=sci-mathematics/octave-4.2.0"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # https://github.com/blink1073/oct2py/issues/77
+ sed \
+ -e 's:test_help:disabled:g' \
+ -i oct2py/tests/test_usage.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die
+ fi
+}
+
+python_test() {
+ unset DISPLAY
+ [[ ${EPYTHON} == python2.7 ]] && local OPTIONS="--with-doctest"
+ nosetests --exe -v oct2py ${OPTIONS} || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ fi
+
+ distutils-r1_python_install_all
+}