summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-10 12:46:37 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-10 12:48:38 +0200
commit42e153391592da77f88cc735368489f073a29ea7 (patch)
treec9b967711108b1085ef105b8080cfd1ba97bc38d /dev-python/openpyxl/openpyxl-3.0.3.ebuild
parentdev-python/et_xmlfile: Port to py3.9 (diff)
downloadgentoo-42e153391592da77f88cc735368489f073a29ea7.tar.gz
gentoo-42e153391592da77f88cc735368489f073a29ea7.tar.bz2
gentoo-42e153391592da77f88cc735368489f073a29ea7.zip
dev-python/openpyxl: Bump to 3.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openpyxl/openpyxl-3.0.3.ebuild')
-rw-r--r--dev-python/openpyxl/openpyxl-3.0.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/openpyxl/openpyxl-3.0.3.ebuild b/dev-python/openpyxl/openpyxl-3.0.3.ebuild
new file mode 100644
index 000000000000..fbd7e799e45c
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-3.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="https://openpyxl.readthedocs.io/en/stable/"
+# Upstream doesn't want to include tests in PyPI tarballs
+# https://bitbucket.org/openpyxl/openpyxl/issues/1308/include-tests-in-pypi-tarballs
+SRC_URI="https://bitbucket.org/${PN}/${PN}/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/jdcal[${PYTHON_USEDEP}]
+ dev-python/et_xmlfile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff,jpeg]
+ )"
+
+distutils_enable_tests pytest