summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-02 09:56:14 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-02 12:47:12 +0100
commit85bc7f4d76a8aea208771894c6917f2d2a3610ad (patch)
tree063d1c115a0c68e1c0a54e4f8bbaa05fc35b8cd4 /dev-python/pillowfight/pillowfight-0.2.ebuild
parentdev-python/testrepository: Backport test fixes (diff)
downloadgentoo-85bc7f4d76a8aea208771894c6917f2d2a3610ad.tar.gz
gentoo-85bc7f4d76a8aea208771894c6917f2d2a3610ad.tar.bz2
gentoo-85bc7f4d76a8aea208771894c6917f2d2a3610ad.zip
dev-python/pillowfight: New package written by me
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pillowfight/pillowfight-0.2.ebuild')
-rw-r--r--dev-python/pillowfight/pillowfight-0.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pillowfight/pillowfight-0.2.ebuild b/dev-python/pillowfight/pillowfight-0.2.ebuild
new file mode 100644
index 000000000000..7ffeb1c10f1b
--- /dev/null
+++ b/dev-python/pillowfight/pillowfight-0.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Eases the transition from PIL to Pillow"
+HOMEPAGE="https://pypi.python.org/pypi/pillowfight/ https://github.com/beanbaginc/pillowfight"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"