summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-01-21 21:48:15 +0100
committerDavid Seifert <soap@gentoo.org>2019-01-21 21:49:08 +0100
commit90a52c99bfcc1a59cd4b69e13e90e2f5bda3e8b3 (patch)
treec8609a6eb11f9ecdbddb57c30a2ce9af8b11beb7 /dev-python/pkgconfig/pkgconfig-1.4.0.ebuild
parentapp-eselect/eselect-ruby: fix broken manifest (diff)
downloadgentoo-90a52c99bfcc1a59cd4b69e13e90e2f5bda3e8b3.tar.gz
gentoo-90a52c99bfcc1a59cd4b69e13e90e2f5bda3e8b3.tar.bz2
gentoo-90a52c99bfcc1a59cd4b69e13e90e2f5bda3e8b3.zip
dev-python/pkgconfig: Version bump to 1.4.0
Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/pkgconfig/pkgconfig-1.4.0.ebuild')
-rw-r--r--dev-python/pkgconfig/pkgconfig-1.4.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pkgconfig/pkgconfig-1.4.0.ebuild b/dev-python/pkgconfig/pkgconfig-1.4.0.ebuild
new file mode 100644
index 000000000000..1823ef123659
--- /dev/null
+++ b/dev-python/pkgconfig/pkgconfig-1.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Interface Python with pkg-config"
+HOMEPAGE="https://pypi.org/project/pkgconfig/ https://github.com/matze/pkgconfig"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="virtual/pkgconfig"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed -e '/nose/d' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die
+}