summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-10-28 17:08:29 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-10-28 17:09:30 +0100
commitad8ffe40040b1d65a5854d6c202842713fd17806 (patch)
tree61db8c71e1f8bdc3db00ee86fddbe94129a318e5 /dev-python/prometheus_client
parentapp-metrics/prometheus: Version bump to 2.4.3 (diff)
downloadgentoo-ad8ffe40040b1d65a5854d6c202842713fd17806.tar.gz
gentoo-ad8ffe40040b1d65a5854d6c202842713fd17806.tar.bz2
gentoo-ad8ffe40040b1d65a5854d6c202842713fd17806.zip
dev-python/prometheus_client: Version bump to 0.4.2
Signed-off-by: Manuel Rüger <mrueg@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/prometheus_client')
-rw-r--r--dev-python/prometheus_client/Manifest1
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.4.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/prometheus_client/Manifest b/dev-python/prometheus_client/Manifest
index 97678a2554f5..367498ea76bd 100644
--- a/dev-python/prometheus_client/Manifest
+++ b/dev-python/prometheus_client/Manifest
@@ -1,3 +1,4 @@
DIST prometheus_client-0.2.0.tar.gz 41574 BLAKE2B c8e0288f37d1d3e6548283105dd6ba1e4cae5a6f1846c776538de1a68a2eebe6387f8212631c07f2c37839204262d0f555f1a5edb624c0d7418753123c296ca4 SHA512 7336d8294ef91dfebe91f325a882105cdaf947de212bff651d1c3ebfc139d9045b7f637ea44b18e921a9f2ad9af554aee28587e57b1202b5a30c49b1a765ba4c
DIST prometheus_client-0.3.0.tar.gz 42186 BLAKE2B 14b116d89493d6c6f04a598accaf5203e30358e93ab666a3025f4436df8dda22265cf86920b149d345aec74870e416360862f64dac9a34b5e8ceccd61b4100a2 SHA512 fa16108428a8531977c3f56fbe564a965c91048d08035d046de6d80f61744f678872d9f4f4108970a047aa6e3ca1b7aa892015a71f49d146cc0a5a8c7a7eba3b
DIST prometheus_client-0.3.1.tar.gz 43185 BLAKE2B 07c69ca13f45c502870dd1eb5934413d71b5e53a5fde7c565414b570a20de183ae1bdda11a34e1c84b874cb5b8491128ff47046632913aaae1c865b0868142aa SHA512 939a985bcf6b377d353871333634ab1641f50288c531ab70b3e5e5466362c02012ae6cf0adf889dac96a89fc5ce29462aa62e651ce21c15d40647d6465baab1a
+DIST prometheus_client-0.4.2.tar.gz 57664 BLAKE2B e98e5c91db13a9f06c2df532e7742545a14cb223e04eba27accc3bdcaf2df949eed2a778194b38e1b4b93908de1636a3cc92a18950db54b5b8f0aceda2d4d2cf SHA512 5e0fee9f9fb4376dcf2959e8285b57a9156d3cf8b9d9118c7b95d2ff63f4dd925bc8cea817bf2fc1ba660e6f5c6dd8f4cf494125cf2a3673443abe0f3a4657c4
diff --git a/dev-python/prometheus_client/prometheus_client-0.4.2.ebuild b/dev-python/prometheus_client/prometheus_client-0.4.2.ebuild
new file mode 100644
index 000000000000..b11eea0b1bae
--- /dev/null
+++ b/dev-python/prometheus_client/prometheus_client-0.4.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="https://pypi.org/project/prometheus_client/"
+SRC_URI="https://github.com/prometheus/client_python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+S=${WORKDIR}/client_python-${PV}
+
+RDEPEND="|| ( dev-python/twisted[${PYTHON_USEDEP}] dev-python/twisted-web[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -v || die
+}