summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-03-29 21:22:59 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-03-29 21:25:22 -0500
commitf4c19704f118b443e4682f3b2d225a8a72a8454f (patch)
treebeccdf717435081f66232e5a8bfaa65fe6e30e32 /dev-python/pychromecast/pychromecast-13.0.6.ebuild
parentsys-libs/libselinux: remove unused pcre2 USE flag from metadata.xml (diff)
downloadgentoo-f4c19704f118b443e4682f3b2d225a8a72a8454f.tar.gz
gentoo-f4c19704f118b443e4682f3b2d225a8a72a8454f.tar.bz2
gentoo-f4c19704f118b443e4682f3b2d225a8a72a8454f.zip
dev-python/pychromecast: add 13.0.6
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/pychromecast/pychromecast-13.0.6.ebuild')
-rw-r--r--dev-python/pychromecast/pychromecast-13.0.6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pychromecast/pychromecast-13.0.6.ebuild b/dev-python/pychromecast/pychromecast-13.0.6.ebuild
new file mode 100644
index 000000000000..0faff3278e61
--- /dev/null
+++ b/dev-python/pychromecast/pychromecast-13.0.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=PyChromecast
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module to talk to Google Chromecast"
+HOMEPAGE="
+ https://github.com/home-assistant-libs/pychromecast/
+ https://pypi.org/project/PyChromecast/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/casttube-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.1[${PYTHON_USEDEP}]
+ >=dev-python/zeroconf-0.25.1[${PYTHON_USEDEP}]
+"