summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-14 11:30:59 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-14 11:45:55 -0600
commit7afdd889287cdc0aee6606d74859afba9936b621 (patch)
tree58bb5320abf26c6566c0bbffe333c72ba98d6f2a /dev-python/pychromecast/pychromecast-4.1.0.ebuild
parentdev-python/casttube: add for pychromecast (diff)
downloadgentoo-7afdd889287cdc0aee6606d74859afba9936b621.tar.gz
gentoo-7afdd889287cdc0aee6606d74859afba9936b621.tar.bz2
gentoo-7afdd889287cdc0aee6606d74859afba9936b621.zip
dev-python/pychromecast: 4.1.0 add for pulseaudio-dlna
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/pychromecast/pychromecast-4.1.0.ebuild')
-rw-r--r--dev-python/pychromecast/pychromecast-4.1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pychromecast/pychromecast-4.1.0.ebuild b/dev-python/pychromecast/pychromecast-4.1.0.ebuild
new file mode 100644
index 000000000000..382fbb243999
--- /dev/null
+++ b/dev-python/pychromecast/pychromecast-4.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="Python module to talk to Google Chromecast."
+HOMEPAGE="https://github.com/balloob/pychromecast"
+SRC_URI="mirror://pypi/P/PyChromecast/PyChromecast-${PV}.tar.gz"
+S="${WORKDIR}/PyChromecast-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/requests-2.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/zeroconf-0.17.7[${PYTHON_USEDEP}]
+ >=dev-python/casttube-0.2.0[${PYTHON_USEDEP}]"
+BDEPEND=""