summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-11-30 23:13:28 -0700
committerTim Harder <radhermit@gentoo.org>2019-11-30 23:13:28 -0700
commita98c96d1bfb89a5e2f07318f0c994a0fc039be4e (patch)
tree249c7efa078950c7149a70c226325fe8cc4b7386 /dev-python/pychroot/pychroot-9999.ebuild
parentdev-python/snakeoil: add missing conditional test RESTRICT (diff)
downloadgentoo-a98c96d1bfb89a5e2f07318f0c994a0fc039be4e.tar.gz
gentoo-a98c96d1bfb89a5e2f07318f0c994a0fc039be4e.tar.bz2
gentoo-a98c96d1bfb89a5e2f07318f0c994a0fc039be4e.zip
dev-python/pychroot: version bump to 0.10.1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/pychroot/pychroot-9999.ebuild')
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index e1419b49ab2e..4f5fc21330e9 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
@@ -24,14 +24,19 @@ RESTRICT="!test? ( test )"
if [[ ${PV} == *9999 ]]; then
RDEPEND="~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
- RDEPEND=">=dev-python/snakeoil-0.8.1[${PYTHON_USEDEP}]"
+ RDEPEND=">=dev-python/snakeoil-0.8.4[${PYTHON_USEDEP}]"
fi
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
-[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
+[[ ${PV} == *9999 ]] && BDEPEND+=" $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')"
+
+python_check_deps() {
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
python_compile_all() {
esetup.py build_man