summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-08-23 04:28:57 -0600
committerTim Harder <radhermit@gentoo.org>2019-08-23 04:29:58 -0600
commite2bcb9c714347c4140af2433e2011663b85d047f (patch)
tree93652fd77be9ad3db1e92004b7eb999685e48626 /dev-python/pychroot
parentsys-devel/patch: Drop old (diff)
downloadgentoo-e2bcb9c714347c4140af2433e2011663b85d047f.tar.gz
gentoo-e2bcb9c714347c4140af2433e2011663b85d047f.tar.bz2
gentoo-e2bcb9c714347c4140af2433e2011663b85d047f.zip
dev-python/pychroot: version bump to 0.10.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/pychroot')
-rw-r--r--dev-python/pychroot/Manifest1
-rw-r--r--dev-python/pychroot/pychroot-0.10.0.ebuild48
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild6
3 files changed, 53 insertions, 2 deletions
diff --git a/dev-python/pychroot/Manifest b/dev-python/pychroot/Manifest
index ad01fc99e305..1cd4cc1350f0 100644
--- a/dev-python/pychroot/Manifest
+++ b/dev-python/pychroot/Manifest
@@ -1 +1,2 @@
+DIST pychroot-0.10.0.tar.gz 23960 BLAKE2B 6d22ccbf3d71854d863577f0cf5ec3b1bea40f0f80d5c07942520d5d522ee299222e96cab4893c9cab93866c7f881052f67ad9091267c329a772fc4c3065bae1 SHA512 4a3941da9a94b75963e72536ec8f6218564dbdcb97e6314562044eb55f523e0704aecbc81e8e377338781e8bfd1a2aafb22cdc82f37bdb198a03e0e30d2323e5
DIST pychroot-0.9.18.tar.gz 32879 BLAKE2B 769b3347bae3f7dfb47c0335015cc898ec851a3d45f774a4e21aeaf9b8d7937331bc69aa5bcbb298e76e7e51ffc2e55f049336fd90f6b08fc3bba87089f2205d SHA512 59c8750c9ba8d601eca485079c04d4153bba92531dbd30fba0104694e4435d76e65b762b76ef89a6a6f8908dd6054d1d95fe4be74825ac1c5a56e473370dfa41
diff --git a/dev-python/pychroot/pychroot-0.10.0.ebuild b/dev-python/pychroot/pychroot-0.10.0.ebuild
new file mode 100644
index 000000000000..e1419b49ab2e
--- /dev/null
+++ b/dev-python/pychroot/pychroot-0.10.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a python library and cli tool that simplify chroot handling"
+HOMEPAGE="https://github.com/pkgcore/pychroot"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND="~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND=">=dev-python/snakeoil-0.8.1[${PYTHON_USEDEP}]"
+fi
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ esetup.py build_man
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst README.rst )
+ esetup.py install_man --mandir="${ED}/usr/share/man"
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index bda4fc26dfd5..e1419b49ab2e 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -19,16 +19,18 @@ HOMEPAGE="https://github.com/pkgcore/pychroot"
LICENSE="BSD"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
if [[ ${PV} == *9999 ]]; then
RDEPEND="~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
- RDEPEND=">=dev-python/snakeoil-0.8.0[${PYTHON_USEDEP}]"
+ RDEPEND=">=dev-python/snakeoil-0.8.1[${PYTHON_USEDEP}]"
fi
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
python_compile_all() {