summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pychroot/pychroot-9999.ebuild')
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index bda4fc26dfd5..e1419b49ab2e 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -19,16 +19,18 @@ HOMEPAGE="https://github.com/pkgcore/pychroot"
LICENSE="BSD"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
if [[ ${PV} == *9999 ]]; then
RDEPEND="~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
- RDEPEND=">=dev-python/snakeoil-0.8.0[${PYTHON_USEDEP}]"
+ RDEPEND=">=dev-python/snakeoil-0.8.1[${PYTHON_USEDEP}]"
fi
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
python_compile_all() {