summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-12-03 01:43:51 -0700
committerTim Harder <radhermit@gentoo.org>2019-12-03 01:46:24 -0700
commitf30860c423bc54be3a7f316eb121fc47349c3aa8 (patch)
treef3e929bb7efaf60fc16f27b9ad17816b1f9b5d10 /dev-python/pychroot
parentmedia-libs/libebur128: ia64 stable wrt bug #700306 (diff)
downloadgentoo-f30860c423bc54be3a7f316eb121fc47349c3aa8.tar.gz
gentoo-f30860c423bc54be3a7f316eb121fc47349c3aa8.tar.bz2
gentoo-f30860c423bc54be3a7f316eb121fc47349c3aa8.zip
dev-python/pychroot: only check for sphinx for live ebuild
Closes: https://bugs.gentoo.org/701862 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/pychroot')
-rw-r--r--dev-python/pychroot/pychroot-0.10.1.ebuild1
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild1
2 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/pychroot/pychroot-0.10.1.ebuild b/dev-python/pychroot/pychroot-0.10.1.ebuild
index 4f5fc21330e9..eaad97eb08ab 100644
--- a/dev-python/pychroot/pychroot-0.10.1.ebuild
+++ b/dev-python/pychroot/pychroot-0.10.1.ebuild
@@ -35,6 +35,7 @@ BDEPEND="
[[ ${PV} == *9999 ]] && BDEPEND+=" $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')"
python_check_deps() {
+ [[ ${PV} == *9999 ]] || return 0
has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
}
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index 4f5fc21330e9..eaad97eb08ab 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -35,6 +35,7 @@ BDEPEND="
[[ ${PV} == *9999 ]] && BDEPEND+=" $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')"
python_check_deps() {
+ [[ ${PV} == *9999 ]] || return 0
has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
}