summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-02-23 21:43:02 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-02-23 21:43:19 +0000
commit1e710dcc7ce830f24cd23998816c4dbb10e7664e (patch)
tree11707decdf70b8ca992557448975670f2305f713 /dev-python/pyds9/files
parentx11-libs/xpa: Version bump (diff)
downloadgentoo-1e710dcc7ce830f24cd23998816c4dbb10e7664e.tar.gz
gentoo-1e710dcc7ce830f24cd23998816c4dbb10e7664e.tar.bz2
gentoo-1e710dcc7ce830f24cd23998816c4dbb10e7664e.zip
dev-python/pyds9: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/pyds9/files')
-rw-r--r--dev-python/pyds9/files/pyds9-1.8.1-use-system-xpa.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyds9/files/pyds9-1.8.1-use-system-xpa.patch b/dev-python/pyds9/files/pyds9-1.8.1-use-system-xpa.patch
new file mode 100644
index 000000000000..b84994f76b08
--- /dev/null
+++ b/dev-python/pyds9/files/pyds9-1.8.1-use-system-xpa.patch
@@ -0,0 +1,36 @@
+Author: Ole Streicher <debian@liska.ath.cx>
+Description: Don't install and use the convienience copy provided in the
+ source, but use the one installed by the "libxpa1" package.
+--- a/setup.py
++++ b/setup.py
+@@ -21,7 +21,7 @@
+ xpadir = 'xpa'
+
+
+-def make(which):
++def _disabled_make(which):
+ curdir = os.getcwd()
+ srcDir = os.path.join(os.path.dirname(os.path.abspath(__file__)), xpadir)
+ os.chdir(srcDir)
+@@ -86,10 +86,5 @@
+ author_email='saord@cfa.harvard.edu',
+ url='http://hea-www.harvard.edu/saord/ds9/',
+ py_modules=['pyds9', 'xpa'],
+- data_files=[('', [os.path.join(xpadir, xpalib),
+- os.path.join(xpadir, xpans)])],
+- cmdclass={'build_py': my_build_py,
+- 'install_data': my_install_data,
+- 'clean': my_clean},
+ install_requires=['six']
+ )
+--- a/xpa.py
++++ b/xpa.py
+@@ -28,7 +28,7 @@
+ return _fname
+ return None
+
+-_libpath = _find_shlib('xpa')
++_libpath = 'libxpa.so.1'
+ if _libpath:
+ libxpa = ctypes.cdll.LoadLibrary(_libpath)
+ _ulist = platform.uname()