summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-26 06:23:33 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-26 06:42:10 +0200
commitfea1d1b69ebee2a5afc4dbd8e143eeff40728a4f (patch)
treeabc2f2bbc18f110ecd38fcbceac38dff2dcb0826 /dev-python/pydyf/pydyf-0.8.0.ebuild
parentdev-python/pylint: Bump to 2.17.6 (diff)
downloadgentoo-fea1d1b69ebee2a5afc4dbd8e143eeff40728a4f.tar.gz
gentoo-fea1d1b69ebee2a5afc4dbd8e143eeff40728a4f.tar.bz2
gentoo-fea1d1b69ebee2a5afc4dbd8e143eeff40728a4f.zip
dev-python/pydyf: Bump to 0.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pydyf/pydyf-0.8.0.ebuild')
-rw-r--r--dev-python/pydyf/pydyf-0.8.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pydyf/pydyf-0.8.0.ebuild b/dev-python/pydyf/pydyf-0.8.0.ebuild
new file mode 100644
index 000000000000..f905c99e37d8
--- /dev/null
+++ b/dev-python/pydyf/pydyf-0.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A low-level PDF generator"
+HOMEPAGE="
+ https://pypi.org/project/pydyf/
+ https://github.com/CourtBouillon/pydyf/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest