summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-26 17:23:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-26 18:48:11 +0100
commit488675987c77bf006333b50e8b144653dd1d202d (patch)
treece05e76ac08f90d2a9126833e82da9eb027e4afd /dev-python/pydyf/pydyf-0.9.0.ebuild
parentdev-python/weasyprint: Bump to 61.1 (diff)
downloadgentoo-488675987c77bf006333b50e8b144653dd1d202d.tar.gz
gentoo-488675987c77bf006333b50e8b144653dd1d202d.tar.bz2
gentoo-488675987c77bf006333b50e8b144653dd1d202d.zip
dev-python/pydyf: Bump to 0.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pydyf/pydyf-0.9.0.ebuild')
-rw-r--r--dev-python/pydyf/pydyf-0.9.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pydyf/pydyf-0.9.0.ebuild b/dev-python/pydyf/pydyf-0.9.0.ebuild
new file mode 100644
index 000000000000..367fc2edc9f9
--- /dev/null
+++ b/dev-python/pydyf/pydyf-0.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A low-level PDF generator"
+HOMEPAGE="
+ https://pypi.org/project/pydyf/
+ https://github.com/CourtBouillon/pydyf/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest