summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydyf/pydyf-0.9.0.ebuild')
-rw-r--r--dev-python/pydyf/pydyf-0.9.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pydyf/pydyf-0.9.0.ebuild b/dev-python/pydyf/pydyf-0.9.0.ebuild
new file mode 100644
index 000000000000..367fc2edc9f9
--- /dev/null
+++ b/dev-python/pydyf/pydyf-0.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A low-level PDF generator"
+HOMEPAGE="
+ https://pypi.org/project/pydyf/
+ https://github.com/CourtBouillon/pydyf/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest