summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-04-08 21:10:16 +0200
committerSebastian Pipping <sping@gentoo.org>2020-04-08 21:10:16 +0200
commit574e253a8b9b94837d64ba7fbe5f350839d922d2 (patch)
treee7c435078cd8ab2b0d63eb20dbc0c0f871a3b19d /dev-python/pyelftools/pyelftools-0.26.ebuild
parentdev-python/pyparsing: 2.4.7 (diff)
downloadgentoo-574e253a8b9b94837d64ba7fbe5f350839d922d2.tar.gz
gentoo-574e253a8b9b94837d64ba7fbe5f350839d922d2.tar.bz2
gentoo-574e253a8b9b94837d64ba7fbe5f350839d922d2.zip
dev-python/pyelftools: 0.26
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.96, Repoman-2.3.22
Diffstat (limited to 'dev-python/pyelftools/pyelftools-0.26.ebuild')
-rw-r--r--dev-python/pyelftools/pyelftools-0.26.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyelftools/pyelftools-0.26.ebuild b/dev-python/pyelftools/pyelftools-0.26.ebuild
new file mode 100644
index 000000000000..ba7b7d895acf
--- /dev/null
+++ b/dev-python/pyelftools/pyelftools-0.26.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="pure-Python library for analyzing ELF files and DWARF debugging information"
+HOMEPAGE="https://pypi.org/project/pyelftools/ https://github.com/eliben/pyelftools"
+# PyPI tarball lacks some test files
+SRC_URI="https://github.com/eliben/pyelftools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+python_test() {
+ # readelf_tests often fails due to host `readelf` changing output format
+ local t
+ for t in all_unittests examples_test ; do
+ "${PYTHON}" ./test/run_${t}.py || die "Tests fail with ${EPYTHON}"
+ done
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}