summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-14 18:48:43 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-14 18:54:21 +0100
commit557dfc134c041eb9624d66ff028e22be922e5096 (patch)
tree65f169e29e8e573ceaf4980a8080e11e3ab847f9 /dev-python/pygsl/pygsl-2.1.1.ebuild
parentdev-python/pygments: Version Bump (diff)
downloadgentoo-557dfc134c041eb9624d66ff028e22be922e5096.tar.gz
gentoo-557dfc134c041eb9624d66ff028e22be922e5096.tar.bz2
gentoo-557dfc134c041eb9624d66ff028e22be922e5096.zip
dev-python/pygsl: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pygsl/pygsl-2.1.1.ebuild')
-rw-r--r--dev-python/pygsl/pygsl-2.1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pygsl/pygsl-2.1.1.ebuild b/dev-python/pygsl/pygsl-2.1.1.ebuild
new file mode 100644
index 000000000000..c093fef498dc
--- /dev/null
+++ b/dev-python/pygsl/pygsl-2.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for the GNU scientific library (gsl)"
+HOMEPAGE="http://pygsl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${P}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND="
+ <sci-libs/gsl-2
+ dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+# Testsuite written to be run post install
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}