summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-02-05 17:47:07 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-02-05 17:48:06 -0800
commitb1c38c971672390a31ff0d3ac89a54d9b0ec8fcb (patch)
tree81bd675b6d0e729c368552e6d0ccc63021628dd1 /dev-python/pymdstat/pymdstat-0.4.2-r1.ebuild
parentdev-games/simgear: Build against sci-libs/gdal:3, bug 688130 (diff)
downloadgentoo-b1c38c971672390a31ff0d3ac89a54d9b0ec8fcb.tar.gz
gentoo-b1c38c971672390a31ff0d3ac89a54d9b0ec8fcb.tar.bz2
gentoo-b1c38c971672390a31ff0d3ac89a54d9b0ec8fcb.zip
dev-python/pymdstat-0.4.2-r1: revbump, enable tests, add py38, EAPI=7
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pymdstat/pymdstat-0.4.2-r1.ebuild')
-rw-r--r--dev-python/pymdstat/pymdstat-0.4.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pymdstat/pymdstat-0.4.2-r1.ebuild b/dev-python/pymdstat/pymdstat-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..1ba2d042f2be
--- /dev/null
+++ b/dev-python/pymdstat/pymdstat-0.4.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Python library to parse Linux /proc/mdstat"
+HOMEPAGE="https://github.com/nicolargo/pymdstat
+ https://pypi.org/project/pymdstat/"
+
+# drop the ${PVR} if there is a version bump
+SRC_URI="https://github.com/nicolargo/${PN}/archive/v${PV}.tar.gz -> ${PN}-${PVR}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( 'AUTHORS' 'NEWS' 'README.rst' )
+
+python_prepare_all() {
+ sed -e '/data_files/ d' -i setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" unitest.py -v || die "testing failed with ${EPYTHON}"
+}