summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-25 07:48:53 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-25 08:06:23 +0100
commit5611d4210213bb22e1220e109015207061a21063 (patch)
treeb179757198777579ed0dcb8823551fe486930845 /dev-python/pypdf/pypdf-3.17.4.ebuild
parentdev-python/recurring-ical-events: Bump to 2.1.2 (diff)
downloadgentoo-5611d4210213bb22e1220e109015207061a21063.tar.gz
gentoo-5611d4210213bb22e1220e109015207061a21063.tar.bz2
gentoo-5611d4210213bb22e1220e109015207061a21063.zip
dev-python/pypdf: Bump to 3.17.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypdf/pypdf-3.17.4.ebuild')
-rw-r--r--dev-python/pypdf/pypdf-3.17.4.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pypdf/pypdf-3.17.4.ebuild b/dev-python/pypdf/pypdf-3.17.4.ebuild
new file mode 100644
index 000000000000..c3de6265ee0d
--- /dev/null
+++ b/dev-python/pypdf/pypdf-3.17.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=964fb47b0fbfa89864680582640ae4eedf143890
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/pypdf/
+ https://github.com/py-pdf/pypdf/
+"
+SRC_URI="
+ https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.0.0[jpeg,jpeg2k,tiff,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+ tests/test_writer.py::test_remove_image_per_type
+ # TODO: requires fpdf
+ tests/test_page.py::test_compression
+ tests/test_writer.py::test_merging_many_temporary_files
+)
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
+ fi
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -m "not enable_socket"
+}