summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-07-04 08:52:45 -0600
committerTim Harder <radhermit@gentoo.org>2019-07-04 08:54:23 -0600
commit5b0cbd6b193e7227f3844a303ec63c83cf289a46 (patch)
treea505234ca0c158b3005e542d7ee6380ce35d5ff3 /dev-python/pyperclip/pyperclip-1.7.0.ebuild
parentmedia-tv/kodi: Add raspberry-pi USE flag (diff)
downloadgentoo-5b0cbd6b193e7227f3844a303ec63c83cf289a46.tar.gz
gentoo-5b0cbd6b193e7227f3844a303ec63c83cf289a46.tar.bz2
gentoo-5b0cbd6b193e7227f3844a303ec63c83cf289a46.zip
dev-python/pyperclip: version bump to 1.7.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/pyperclip/pyperclip-1.7.0.ebuild')
-rw-r--r--dev-python/pyperclip/pyperclip-1.7.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyperclip/pyperclip-1.7.0.ebuild b/dev-python/pyperclip/pyperclip-1.7.0.ebuild
new file mode 100644
index 000000000000..6b173121f867
--- /dev/null
+++ b/dev-python/pyperclip/pyperclip-1.7.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy)
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A cross-platform clipboard module for Python."
+HOMEPAGE="https://github.com/asweigart/pyperclip"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ || (
+ x11-misc/xclip
+ x11-misc/xsel
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pygtk[${PYTHON_USEDEP}]' python2_7)
+ )
+"
+
+python_prepare_all() {
+ # make tests a proper module so setuptools can find the test suite
+ touch tests/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ virtx esetup.py test
+}