summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVasilyLebedev <vasily.lebedev@ul.ie>2020-08-29 16:58:17 +0000
committerSam James <sam@gentoo.org>2020-09-04 21:11:01 +0000
commit7724cf2bf504167b89f8522a7240e03ab3061aac (patch)
treebdf16ec449ecf5759faee641bb0a07d334a2b13b /dev-python/pyqt-distutils/pyqt-distutils-0.7.3.ebuild
parentdev-python/pyqt-distutils: cleanup old 0.3.0 (diff)
downloadgentoo-7724cf2bf504167b89f8522a7240e03ab3061aac.tar.gz
gentoo-7724cf2bf504167b89f8522a7240e03ab3061aac.tar.bz2
gentoo-7724cf2bf504167b89f8522a7240e03ab3061aac.zip
dev-python/pyqt-distutils: version bump to 0.7.3
Works with Python 3.{6..9}. Bug: https://bugs.gentoo.org/719428 Closes: https://bugs.gentoo.org/719428 Closes: https://github.com/gentoo/gentoo/pull/17317 Signed-off-by: Vasily A. Lebedev <lebedev.vasya@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyqt-distutils/pyqt-distutils-0.7.3.ebuild')
-rw-r--r--dev-python/pyqt-distutils/pyqt-distutils-0.7.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pyqt-distutils/pyqt-distutils-0.7.3.ebuild b/dev-python/pyqt-distutils/pyqt-distutils-0.7.3.ebuild
new file mode 100644
index 000000000000..7679856ab818
--- /dev/null
+++ b/dev-python/pyqt-distutils/pyqt-distutils-0.7.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="distutils extension to work with PyQt applications and UI files"
+HOMEPAGE="https://github.com/ColinDuquesnoy/pyqt_distutils"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/ColinDuquesnoy/pyqt_distutils/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest