summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-18 22:16:46 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-18 23:28:17 +0100
commit427e95d435eecf60aa139fafc4dd1b2a13820f20 (patch)
treeb2deff3fdacf131c8a14986e9f92d5bc26fab916 /dev-python/pyscard/pyscard-2.0.3.ebuild
parentdev-python/pytest-subtests: Remove old (diff)
downloadgentoo-427e95d435eecf60aa139fafc4dd1b2a13820f20.tar.gz
gentoo-427e95d435eecf60aa139fafc4dd1b2a13820f20.tar.bz2
gentoo-427e95d435eecf60aa139fafc4dd1b2a13820f20.zip
dev-python/pyscard: Bump to 2.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyscard/pyscard-2.0.3.ebuild')
-rw-r--r--dev-python/pyscard/pyscard-2.0.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyscard/pyscard-2.0.3.ebuild b/dev-python/pyscard/pyscard-2.0.3.ebuild
new file mode 100644
index 000000000000..2eefa09fd4bc
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard
+ https://pypi.org/project/pyscard/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="sys-apps/pcsc-lite"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/swig"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/Pyro4
+}
+
+python_test() {
+ cd test || die
+ eunittest
+}