summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2019-12-18 19:12:22 +0100
committerConrad Kostecki <conikost@gentoo.org>2019-12-18 19:17:58 +0100
commitb849d08770a7b44a790313d8ff9fdb5a5baac15a (patch)
tree5844fd967bec379e85fe146e050061a63d3b78ee /dev-python/pyspectrum2/pyspectrum2-0.2.0.ebuild
parentnet-im/yowsup: bump to version 3.2.3_p20190905 (diff)
downloadgentoo-b849d08770a7b44a790313d8ff9fdb5a5baac15a.tar.gz
gentoo-b849d08770a7b44a790313d8ff9fdb5a5baac15a.tar.bz2
gentoo-b849d08770a7b44a790313d8ff9fdb5a5baac15a.zip
dev-python/pyspectrum2: New package
Will be needed as a new dependency for python3-enabled net-im/transwhat. Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/pyspectrum2/pyspectrum2-0.2.0.ebuild')
-rw-r--r--dev-python/pyspectrum2/pyspectrum2-0.2.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyspectrum2/pyspectrum2-0.2.0.ebuild b/dev-python/pyspectrum2/pyspectrum2-0.2.0.ebuild
new file mode 100644
index 000000000000..162ca0316ca4
--- /dev/null
+++ b/dev-python/pyspectrum2/pyspectrum2-0.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements a protobuf-based interface for Spectrum2 python-based backends"
+HOMEPAGE="https://github.com/stv0g/pyspectrum2"
+SRC_URI="https://github.com/stv0g/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/protobuf-python[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ python_optimize
+}