summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-22 08:41:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-22 09:34:31 +0200
commit45e3ec34c757a8480a09689c64486f12d73d65ed (patch)
treec27c3305ea252484b81674fa6e0beac6f1772441 /dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild
parentdev-python/sqlalchemy: Remove buggy 1.4* versions (diff)
downloadgentoo-45e3ec34c757a8480a09689c64486f12d73d65ed.tar.gz
gentoo-45e3ec34c757a8480a09689c64486f12d73d65ed.tar.bz2
gentoo-45e3ec34c757a8480a09689c64486f12d73d65ed.zip
dev-python/pytest-asyncio: Bump to 0.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild')
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild
new file mode 100644
index 000000000000..60f1a55ba4e7
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.15.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+ https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest