summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-05 20:36:52 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-05 20:36:52 -0800
commit4480ad059cf7edb93dee4f70790c940951bde781 (patch)
treef863cb7a34c2bc09f4ece0fe6647799bbe8ac278 /dev-python/pytest-cov/pytest-cov-2.8.1.ebuild
parentdev-lua/lua-openssl-0.7.7_p0-r1: revbump, fix libdir (diff)
downloadgentoo-4480ad059cf7edb93dee4f70790c940951bde781.tar.gz
gentoo-4480ad059cf7edb93dee4f70790c940951bde781.tar.bz2
gentoo-4480ad059cf7edb93dee4f70790c940951bde781.zip
dev-python/pytest-cov-2.8.1: Add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytest-cov/pytest-cov-2.8.1.ebuild')
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.8.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild b/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild
index 45ad4ec70c7d..ac1732bd7f24 100644
--- a/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild
+++ b/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
inherit distutils-r1
@@ -35,6 +35,9 @@ DEPEND="
PATCHES=(
# Bug 597708
"${FILESDIR}/${PN}-2.8.1-disable-broken-tests.patch"
+ "${FILESDIR}/${PN}-2.8.1-latest-setuptools.patch"
+ # https://github.com/pytest-dev/pytest-cov/issues/365
+ "${FILESDIR}/pytest-cov-2.8.1-python38.patch"
)
distutils_enable_sphinx docs \