summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-04 06:01:37 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-04 06:01:37 +0200
commit3d581866e0c77e060a75e866fba26615149c6164 (patch)
treeeca926b29b472d75119ecf3343a8dfbd18766801 /dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild
parentdev-python/rarfile: Bump to 4.2 (diff)
downloadgentoo-3d581866e0c77e060a75e866fba26615149c6164.tar.gz
gentoo-3d581866e0c77e060a75e866fba26615149c6164.tar.bz2
gentoo-3d581866e0c77e060a75e866fba26615149c6164.zip
dev-python/pytest-jupyter: Bump to 0.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild')
-rw-r--r--dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild b/dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild
new file mode 100644
index 000000000000..ac7134dabd4e
--- /dev/null
+++ b/dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for testing Jupyter libraries and extensions"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/pytest-jupyter/
+ https://pypi.org/project/pytest-jupyter/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-7.4.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-5.7[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest