summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-31 20:00:08 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-31 20:46:24 +0000
commitf22256162423c3b22dc3df63ae40ffd33dc78514 (patch)
tree660089776e45b3cd2add48d371a19f46073a80d7 /dev-python/pytest-runner/pytest-runner-2.11.1.ebuild
parentdev-python/pytest-mpl: version bump (diff)
downloadgentoo-f22256162423c3b22dc3df63ae40ffd33dc78514.tar.gz
gentoo-f22256162423c3b22dc3df63ae40ffd33dc78514.tar.bz2
gentoo-f22256162423c3b22dc3df63ae40ffd33dc78514.zip
dev-python/pytest-runner: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/pytest-runner/pytest-runner-2.11.1.ebuild')
-rw-r--r--dev-python/pytest-runner/pytest-runner-2.11.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-runner/pytest-runner-2.11.1.ebuild b/dev-python/pytest-runner/pytest-runner-2.11.1.ebuild
new file mode 100644
index 000000000000..1717adcb2432
--- /dev/null
+++ b/dev-python/pytest-runner/pytest-runner-2.11.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds support for tests during installation of setup.py files"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-runner https://bitbucket.org/pytest-dev/pytest-runner"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? ( ${RDEPEND} )
+"
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ fi
+}
+
+python_test() {
+ esetup.py pytest
+}