summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-20 23:10:38 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-21 01:12:26 -0400
commitad02021a2b7af45cfa235baa25886ac1bfdac833 (patch)
treec7b15dae9b35b01d4b11d478474f3504a45fd34b /dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild
parentdev-python/pytest-fixture-config: version bump to 1.2.11 (diff)
downloadgentoo-ad02021a2b7af45cfa235baa25886ac1bfdac833.tar.gz
gentoo-ad02021a2b7af45cfa235baa25886ac1bfdac833.tar.bz2
gentoo-ad02021a2b7af45cfa235baa25886ac1bfdac833.zip
dev-python/pytest-shutil: version bump to 1.2.11
Diffstat (limited to 'dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild')
-rw-r--r--dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild b/dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild
new file mode 100644
index 000000000000..9e003f9243ec
--- /dev/null
+++ b/dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A goodie-bag of unix shell and environment tools for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.python.org/pypi/pytest-shutil"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+"
+
+python_test() {
+ esetup.py test
+}