summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:44:26 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:54:41 +0200
commite110c14411783acc64ba89300bf266e77a8cf65f (patch)
tree44141458524f8c9a0291acda06f1a0884eefc254 /dev-python/pytest-shutil
parentdev-python/pytest-salt: Remove redundant versions (diff)
downloadgentoo-e110c14411783acc64ba89300bf266e77a8cf65f.tar.gz
gentoo-e110c14411783acc64ba89300bf266e77a8cf65f.tar.bz2
gentoo-e110c14411783acc64ba89300bf266e77a8cf65f.zip
dev-python/pytest-shutil: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-shutil')
-rw-r--r--dev-python/pytest-shutil/Manifest1
-rw-r--r--dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild39
2 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/pytest-shutil/Manifest b/dev-python/pytest-shutil/Manifest
index 8274ff9c3053..f72bfbdf3cc0 100644
--- a/dev-python/pytest-shutil/Manifest
+++ b/dev-python/pytest-shutil/Manifest
@@ -1,2 +1 @@
-DIST pytest-shutil-1.2.11.tar.gz 18310 BLAKE2B a85f50a8a0e98de6dd71af0b27f76181b1ff80b518877155122998c3f8992c2749ebcc837d630dc19d60d988410eba8dc77b1be7faff7cf27003ebbba9194bcc SHA512 2a998218bb997a6ceb277965e2f150b2d7722ba518f579154f804568f552e2c41ced9a491c1745382dc119d0b92f3ea993ae77a61851809aae59a1e17501bde8
DIST pytest-shutil-1.7.0.tar.gz 23497 BLAKE2B e13641491fb4bd448973b8004ac9ded2f9b7c412ea93af7f9206e5fc38ea7554073374116eeefc529d2ae35e8a25e678fef5a27089af89026077a72d11d6016d SHA512 3746c08b17834621a7142ed9d5915b5c348c13367f5b423b258d3471bcb9c9e983c61c25ca936f879b8b82f80512512b7f3ade5555c24a790c72b502e3f3d144
diff --git a/dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild b/dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild
deleted file mode 100644
index b4eecc6c24f3..000000000000
--- a/dev-python/pytest-shutil/pytest-shutil-1.2.11.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A goodie-bag of unix shell and environment tools for py.test"
-HOMEPAGE="https://github.com/man-group/pytest-plugins https://pypi.org/project/pytest-shutil/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
-IUSE="test"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/execnet[${PYTHON_USEDEP}]
- dev-python/contextlib2[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/path-py[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools-git[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )
-"
-RESTRICT="!test? ( test )"
-
-python_test() {
- # various pickling errors, but code works to run pytest-virtualenv tests
- [[ ${EPYTHON} == pypy ]] && return
-
- esetup.py test
-}