summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWim Muskee <wimmuskee@gmail.com>2019-10-21 05:07:07 +0200
committerMatthew Thode <prometheanfire@gentoo.org>2019-10-21 14:50:10 -0500
commitcfc0221a1c5b43122e586584a1814ae8cd7ea424 (patch)
treec8c7aaa100af92aef3a1d193621a73ab97b77436 /dev-python/python-augeas/python-augeas-1.0.3.ebuild
parentsys-apps/portage: fixup 2.3.78 GetConfigTestCase (diff)
downloadgentoo-cfc0221a1c5b43122e586584a1814ae8cd7ea424.tar.gz
gentoo-cfc0221a1c5b43122e586584a1814ae8cd7ea424.tar.bz2
gentoo-cfc0221a1c5b43122e586584a1814ae8cd7ea424.zip
dev-python/python-augeas: bump to 1.0.3
Closes: https://bugs.gentoo.org/678946 Signed-off-by: Wim Muskee <wimmuskee@gmail.com> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-augeas/python-augeas-1.0.3.ebuild')
-rw-r--r--dev-python/python-augeas/python-augeas-1.0.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-augeas/python-augeas-1.0.3.ebuild b/dev-python/python-augeas/python-augeas-1.0.3.ebuild
new file mode 100644
index 000000000000..10b466c7506f
--- /dev/null
+++ b/dev-python/python-augeas/python-augeas-1.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Augeas"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="app-admin/augeas
+ >=dev-python/cffi-1.0.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ cd test && "${PYTHON}" test_augeas.py || die
+}