summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-13 21:00:46 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-13 21:21:27 +0200
commitc9fcebb00c2a27f09855bdc8f332a6bccc9f552a (patch)
tree3c0db95ac521f658354c3936d7c3b18a89c55c74 /dev-python/python-dotenv
parentdev-python/sh: bump to 1.14.0, add Python 3.9 support (diff)
downloadgentoo-c9fcebb00c2a27f09855bdc8f332a6bccc9f552a.tar.gz
gentoo-c9fcebb00c2a27f09855bdc8f332a6bccc9f552a.tar.bz2
gentoo-c9fcebb00c2a27f09855bdc8f332a6bccc9f552a.zip
dev-python/python-dotenv: add Python 3.9 support, fix deps and tests
Tests run fine, however they require IPython. Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/python-dotenv')
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.14.0.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild b/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild
index 6bb296513f85..f73be0464463 100644
--- a/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild
+++ b/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -19,12 +19,11 @@ IUSE="test"
DEPEND="test? (
>=dev-python/click-5[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/sh-1.09[${PYTHON_USEDEP}]
)"
-RESTRICT="test" # help fixing tests welcome, please get in touch
-
DOCS=( CHANGELOG.md README.md )
distutils_enable_tests pytest