summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJouni Kosonen <jouni.kosonen@tukesoft.com>2020-02-16 11:23:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-16 14:41:31 +0100
commit8e83a436d747f99f68445746ab19f7aade4c90bb (patch)
tree82a0fc9e80dac4bfa901f5355aa1cf4bb8655f03 /dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild
parentmedia-sound/frescobaldi: version bump to 3.1.1 (diff)
downloadgentoo-8e83a436d747f99f68445746ab19f7aade4c90bb.tar.gz
gentoo-8e83a436d747f99f68445746ab19f7aade4c90bb.tar.bz2
gentoo-8e83a436d747f99f68445746ab19f7aade4c90bb.zip
dev-python/python-poppler-qt5: version bump to 0.75.0
Add python3_7 support to enable same for media-sound/frescobaldi Signed-off-by: Jouni Kosonen <jouni.kosonen@tukesoft.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild')
-rw-r--r--dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild b/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild
new file mode 100644
index 000000000000..d936a77a1d84
--- /dev/null
+++ b/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="A python binding for libpoppler-qt5"
+HOMEPAGE="https://github.com/wbsoft/python-poppler-qt5"
+SRC_URI="https://github.com/wbsoft/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/poppler[qt5]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ >=dev-python/sip-4.19:=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"