summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-17 09:58:46 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-17 10:14:55 +0100
commit932b87d43d5a4fb4d67c80674586fedbfa7623f8 (patch)
tree1f7c646e0a6a0cd79bef4defb9234b1ca801b9a1 /dev-python/python-socks
parentdev-python/tempest: Remove the test dep on hacking (diff)
downloadgentoo-932b87d43d5a4fb4d67c80674586fedbfa7623f8.tar.gz
gentoo-932b87d43d5a4fb4d67c80674586fedbfa7623f8.tar.bz2
gentoo-932b87d43d5a4fb4d67c80674586fedbfa7623f8.zip
dev-python/python-socks: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-socks')
-rw-r--r--dev-python/python-socks/Manifest1
-rw-r--r--dev-python/python-socks/python-socks-2.0.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index bd151d7bb157..4c8c4f127e9a 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1,2 +1,3 @@
DIST python-socks-1.2.4.gh.tar.gz 32192 BLAKE2B fa06f9158348292bef874c81623c11a54556db9c36cd7428d7a835428d152f3a4925d59e14d87518dfaae9e6937324e35db99bb5e1000f29fe9caf11fa2f8318 SHA512 6e70d8d98b2901e97250d30b350002944d979356bb6cd7dd4022af420e166076259a7b1aa4845d771243b18ab3f06ee955f07482c527835bb0135f0622d804be
DIST python-socks-2.0.0.gh.tar.gz 38176 BLAKE2B 84711bd6747dd9ef8d7f47d90e7e1beeb99db7c51a370c01a272789e7d5356cdf3d0e3b1e822e1beb88a29ebbe23acac8f68206cf7a3f8b924f79d3783426f93 SHA512 088a606ca6e13de79cfa8b180d76e91cca129b3e1ffad2243e5924dc10530340924ea815eb9af0e53b5369daa9cf3e66b2f623da6913ed32916b91d24a47c1e4
+DIST python-socks-2.0.1.gh.tar.gz 40710 BLAKE2B 185131be6e2ef85e3d1cb41ff03e57c1d3e8921c04d11df4d3e1d3c7ed6f3cd10459730d0cc5ad63981dcfe0f8cd987f0f287a70f6727727550d63c0ff6040bc SHA512 08afe55b9a5e8d1c0aa5150511e7d3918fd8c6da10bb80037baa4f3c8004fa9e50b30ce7bda26e73f77208b64cb85544029ffd2edf197f6a23614b3c7f56114b
diff --git a/dev-python/python-socks/python-socks-2.0.1.ebuild b/dev-python/python-socks/python-socks-2.0.1.ebuild
new file mode 100644
index 000000000000..94d2cb6ce6da
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://pypi.org/project/python-socks/
+ https://github.com/romis2012/python-socks/"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="dev-python/async_timeout[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest