summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-12 09:58:16 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-12 10:48:55 +0100
commit8b00c8780928849c2f086378087d9d5292713936 (patch)
tree7e5468c558c1b8c12f190c272c597d5a0a02fb14 /dev-python/python-stdnum/python-stdnum-1.15.ebuild
parentdev-python/pygments: Bump to 2.7.4 (diff)
downloadgentoo-8b00c8780928849c2f086378087d9d5292713936.tar.gz
gentoo-8b00c8780928849c2f086378087d9d5292713936.tar.bz2
gentoo-8b00c8780928849c2f086378087d9d5292713936.zip
dev-python/python-stdnum: Bump to 1.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-stdnum/python-stdnum-1.15.ebuild')
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.15.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/python-stdnum-1.15.ebuild b/dev-python/python-stdnum/python-stdnum-1.15.ebuild
new file mode 100644
index 000000000000..5ec38434f38b
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.15.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="https://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies"
+
+RDEPEND="
+ vies? (
+ || (
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/suds[${PYTHON_USEDEP}]
+ )
+ )"
+
+DOCS=( ChangeLog NEWS README )
+
+distutils_enable_tests nose