summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2018-10-27 19:54:00 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-30 10:07:29 +0100
commit595d14eaf504aef961cc6a7831b37306c408831c (patch)
treea4b7521f6ea353c310c0387d201121f867ce6f0f /dev-python/pytidylib/pytidylib-0.3.2.ebuild
parentsys-libs/compiler-rt-sanitizers: Rebase patches for -9999 (diff)
downloadgentoo-595d14eaf504aef961cc6a7831b37306c408831c.tar.gz
gentoo-595d14eaf504aef961cc6a7831b37306c408831c.tar.bz2
gentoo-595d14eaf504aef961cc6a7831b37306c408831c.zip
dev-python/pytidylib: Bump to 0.3.2 and add python3_7 support
Signed-off-by: Nils Freydank <holgersson@posteo.de> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytidylib/pytidylib-0.3.2.ebuild')
-rw-r--r--dev-python/pytidylib/pytidylib-0.3.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytidylib/pytidylib-0.3.2.ebuild b/dev-python/pytidylib/pytidylib-0.3.2.ebuild
new file mode 100644
index 000000000000..1edb2743c4b4
--- /dev/null
+++ b/dev-python/pytidylib/pytidylib-0.3.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for HTML Tidy (tidylib)"
+HOMEPAGE="http://countergram.com/open-source/pytidylib https://github.com/countergram/pytidylib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND="app-text/htmltidy
+ dev-python/setuptools"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -vv || die
+}