summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-16 14:44:51 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-16 14:53:14 +0100
commit17a59885500311537abba7b56e84107cc724052e (patch)
tree5bf07a16a223a9c10378ba88a6d2cc25032df339 /dev-python/pytz/pytz-2019.3.ebuild
parentdev-python/iso8601: Enable py3.8 (diff)
downloadgentoo-17a59885500311537abba7b56e84107cc724052e.tar.gz
gentoo-17a59885500311537abba7b56e84107cc724052e.tar.bz2
gentoo-17a59885500311537abba7b56e84107cc724052e.zip
dev-python/pytz: Bump to 2019.3, py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytz/pytz-2019.3.ebuild')
-rw-r--r--dev-python/pytz/pytz-2019.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytz/pytz-2019.3.ebuild b/dev-python/pytz/pytz-2019.3.ebuild
new file mode 100644
index 000000000000..2b38219a923d
--- /dev/null
+++ b/dev-python/pytz/pytz-2019.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="https://pythonhosted.org/pytz/ https://pypi.org/project/pytz/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE=""
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ || ( >=sys-libs/timezone-data-2017a sys-libs/glibc[vanilla] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+PATCHES=(
+ # Use timezone-data zoneinfo.
+ "${FILESDIR}"/2018.4-zoneinfo.patch
+ # ...and do not install a copy of it.
+ "${FILESDIR}"/${PN}-2018.4-zoneinfo-noinstall.patch
+)
+
+python_test() {
+ "${EPYTHON}" pytz/tests/test_tzinfo.py -v || die "Tests fail with ${EPYTHON}"
+}