summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyxenstore
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyxenstore')
-rw-r--r--dev-python/pyxenstore/Manifest1
-rw-r--r--dev-python/pyxenstore/metadata.xml15
-rw-r--r--dev-python/pyxenstore/pyxenstore-0.0.2.ebuild20
-rw-r--r--dev-python/pyxenstore/pyxenstore-9999.ebuild22
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pyxenstore/Manifest b/dev-python/pyxenstore/Manifest
new file mode 100644
index 000000000000..306fb18d6812
--- /dev/null
+++ b/dev-python/pyxenstore/Manifest
@@ -0,0 +1 @@
+DIST pyxenstore-0.0.2.tar.gz 4471 SHA256 a495add5b6f3f2f524d70b37b068f5e7f69f4e3fa9dc5602d13a6507e8a10a5a SHA512 0c4cfccd1f943d39f0524798504069514bd811886714b121cf03addb344ca4aa10a718178b3e8eb1cfc9ac9e4c2d6e61a1bbfaa47e1ec4941a7429e629f982d0 WHIRLPOOL 8cc88f1786c28495f601c0a055cfbe33387cf8f8eafc1d1e5739648576e30766ac0f93380fb1a05bec53f2e9965a76ce2106bc33e6d7ab3f6e1bd8e2fb4522c7
diff --git a/dev-python/pyxenstore/metadata.xml b/dev-python/pyxenstore/metadata.xml
new file mode 100644
index 000000000000..028202ff94bd
--- /dev/null
+++ b/dev-python/pyxenstore/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyxenstore</remote-id>
+ <remote-id type="launchpad">pyxenstore</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyxenstore/pyxenstore-0.0.2.ebuild b/dev-python/pyxenstore/pyxenstore-0.0.2.ebuild
new file mode 100644
index 000000000000..eabac3ba68c1
--- /dev/null
+++ b/dev-python/pyxenstore/pyxenstore-0.0.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides Python interfaces for Xen's XenStore"
+HOMEPAGE="https://launchpad.net/pyxenstore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND="app-emulation/xen-tools"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/pyxenstore/pyxenstore-9999.ebuild b/dev-python/pyxenstore/pyxenstore-9999.ebuild
new file mode 100644
index 000000000000..05b96a7957d7
--- /dev/null
+++ b/dev-python/pyxenstore/pyxenstore-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 bzr
+
+EBZR_REPO_URI="https://code.launchpad.net/~cbehrens/pyxenstore/trunk"
+
+DESCRIPTION="Provides Python interfaces for Xen's XenStore"
+HOMEPAGE="https://launchpad.net/pyxenstore"
+SRC_URI=""
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="app-emulation/xen-tools"
+RDEPEND="${DEPEND}"