summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyxenstore')
-rw-r--r--dev-python/pyxenstore/Manifest1
-rw-r--r--dev-python/pyxenstore/metadata.xml15
-rw-r--r--dev-python/pyxenstore/pyxenstore-0.0.2.ebuild20
-rw-r--r--dev-python/pyxenstore/pyxenstore-9999.ebuild22
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pyxenstore/Manifest b/dev-python/pyxenstore/Manifest
new file mode 100644
index 000000000000..306fb18d6812
--- /dev/null
+++ b/dev-python/pyxenstore/Manifest
@@ -0,0 +1 @@
+DIST pyxenstore-0.0.2.tar.gz 4471 SHA256 a495add5b6f3f2f524d70b37b068f5e7f69f4e3fa9dc5602d13a6507e8a10a5a SHA512 0c4cfccd1f943d39f0524798504069514bd811886714b121cf03addb344ca4aa10a718178b3e8eb1cfc9ac9e4c2d6e61a1bbfaa47e1ec4941a7429e629f982d0 WHIRLPOOL 8cc88f1786c28495f601c0a055cfbe33387cf8f8eafc1d1e5739648576e30766ac0f93380fb1a05bec53f2e9965a76ce2106bc33e6d7ab3f6e1bd8e2fb4522c7
diff --git a/dev-python/pyxenstore/metadata.xml b/dev-python/pyxenstore/metadata.xml
new file mode 100644
index 000000000000..028202ff94bd
--- /dev/null
+++ b/dev-python/pyxenstore/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyxenstore</remote-id>
+ <remote-id type="launchpad">pyxenstore</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyxenstore/pyxenstore-0.0.2.ebuild b/dev-python/pyxenstore/pyxenstore-0.0.2.ebuild
new file mode 100644
index 000000000000..eabac3ba68c1
--- /dev/null
+++ b/dev-python/pyxenstore/pyxenstore-0.0.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides Python interfaces for Xen's XenStore"
+HOMEPAGE="https://launchpad.net/pyxenstore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND="app-emulation/xen-tools"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/pyxenstore/pyxenstore-9999.ebuild b/dev-python/pyxenstore/pyxenstore-9999.ebuild
new file mode 100644
index 000000000000..05b96a7957d7
--- /dev/null
+++ b/dev-python/pyxenstore/pyxenstore-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 bzr
+
+EBZR_REPO_URI="https://code.launchpad.net/~cbehrens/pyxenstore/trunk"
+
+DESCRIPTION="Provides Python interfaces for Xen's XenStore"
+HOMEPAGE="https://launchpad.net/pyxenstore"
+SRC_URI=""
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="app-emulation/xen-tools"
+RDEPEND="${DEPEND}"