summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-02 12:46:20 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-02 13:05:33 +0200
commitb3aba78ec2165923f5daa285011325a1e335a706 (patch)
tree814e3b18fc7a3355e45150e554ad1d6705768c74 /dev-python/rfc3986/rfc3986-0.2.2.ebuild
parentdev-python/strict-rfc3339: Add pypy support (diff)
downloadgentoo-b3aba78ec2165923f5daa285011325a1e335a706.tar.gz
gentoo-b3aba78ec2165923f5daa285011325a1e335a706.tar.bz2
gentoo-b3aba78ec2165923f5daa285011325a1e335a706.zip
dev-python/rfc3986: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/rfc3986/rfc3986-0.2.2.ebuild')
-rw-r--r--dev-python/rfc3986/rfc3986-0.2.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/rfc3986/rfc3986-0.2.2.ebuild b/dev-python/rfc3986/rfc3986-0.2.2.ebuild
new file mode 100644
index 000000000000..3099989634ed
--- /dev/null
+++ b/dev-python/rfc3986/rfc3986-0.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="http://tools.ietf.org/html/rfc3986 https://github.com/sigmavirus24/rfc3986 https://rfc3986.rtfd.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_test() {
+ py.test || die
+}