summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-06 09:23:58 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-06 09:58:03 +0200
commit94ef9278bb6967b69db78057601a560e86ca74ec (patch)
tree5f9367970dfe45ac1f46a953452f273503ff3012 /dev-python/rich/rich-10.5.0.ebuild
parentdev-python/sphinx: Bump to 4.0.3 (diff)
downloadgentoo-94ef9278bb6967b69db78057601a560e86ca74ec.tar.gz
gentoo-94ef9278bb6967b69db78057601a560e86ca74ec.tar.bz2
gentoo-94ef9278bb6967b69db78057601a560e86ca74ec.zip
dev-python/rich: Bump to 10.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rich/rich-10.5.0.ebuild')
-rw-r--r--dev-python/rich/rich-10.5.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/rich/rich-10.5.0.ebuild b/dev-python/rich/rich-10.5.0.ebuild
new file mode 100644
index 000000000000..6d4831ee5fd9
--- /dev/null
+++ b/dev-python/rich/rich-10.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}