summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-02-25 19:32:53 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-02-25 20:13:45 +0000
commit727d16b5730f00102d6161d216bd76d462342bb1 (patch)
tree0035ef91e20c2f3924ad1ba932e0c224966d70d8 /dev-python/slixmpp/slixmpp-1.4.2.ebuild
parentdev-python/slixmpp: 9999: add dep on aiohttp (diff)
downloadgentoo-727d16b5730f00102d6161d216bd76d462342bb1.tar.gz
gentoo-727d16b5730f00102d6161d216bd76d462342bb1.tar.bz2
gentoo-727d16b5730f00102d6161d216bd76d462342bb1.zip
dev-python/slixmpp: add new version 1.4.2
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'dev-python/slixmpp/slixmpp-1.4.2.ebuild')
-rw-r--r--dev-python/slixmpp/slixmpp-1.4.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/slixmpp/slixmpp-1.4.2.ebuild b/dev-python/slixmpp/slixmpp-1.4.2.ebuild
new file mode 100644
index 000000000000..aebd4d6f2603
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-1.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://dev.louiz.org/projects/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-dns/libidn
+ test? ( $RDEPEND )
+"
+
+python_test() {
+ esetup.py test
+}