summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-23 09:44:31 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-23 09:49:10 +0100
commitbe7fb3a688dc98c4fc033732f7757adb165c2656 (patch)
tree89b254558945525e1a737958984106146bc45d0c /dev-python/smmap/smmap-3.0.5.ebuild
parentdev-python/diskcache: Bump to 5.2.1 (diff)
downloadgentoo-be7fb3a688dc98c4fc033732f7757adb165c2656.tar.gz
gentoo-be7fb3a688dc98c4fc033732f7757adb165c2656.tar.bz2
gentoo-be7fb3a688dc98c4fc033732f7757adb165c2656.zip
dev-python/smmap: Bump to 3.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/smmap/smmap-3.0.5.ebuild')
-rw-r--r--dev-python/smmap/smmap-3.0.5.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/smmap/smmap-3.0.5.ebuild b/dev-python/smmap/smmap-3.0.5.ebuild
new file mode 100644
index 000000000000..c3e03ccc7752
--- /dev/null
+++ b/dev-python/smmap/smmap-3.0.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python implementation of a sliding window memory map manager"
+HOMEPAGE="
+ https://pypi.org/project/smmap/
+ https://github.com/gitpython-developers/smmap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm64 ~x86"
+SLOT="0"
+
+distutils_enable_tests unittest